CODESYS форум

Добро пожаловать на официальный форум CODESYS, 3S-Smart Software Solutions GmbH | A member of the CODESYS Group
Deutsche Version English version russian version 
Текущее время: Вс дек 15, 2019 6:44 am

Часовой пояс: UTC+01:00




Начать новую тему  Ответить на тему  [ 27 сообщений ]  На страницу Пред. 1 2
Автор Сообщение
 Заголовок сообщения:
СообщениеДобавлено: Вт апр 14, 2009 11:20 am 
Не в сети
Site Admin

Зарегистрирован: Ср июл 20, 2005 2:32 pm
Сообщения: 153
Действительно, пробовали со старой версией...

:arrow: См. ответ тут.


Вернуться к началу
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 11, 2010 10:56 am 
Не в сети

Зарегистрирован: Пн сен 28, 2009 1:14 pm
Сообщения: 0
Здравствуйте. Прочитал данную тему про кирилические шрифты в целевой и веб-визуализации, но так и не нашел конкретного ответа. У меня как раз контроллер ThinkIO. Как добиться отображения русских шрифтов в целевой визуализации? Смотрел те шрифты, что установлены на контроллере, русский в них есть. Следовательно ошибка в кодировке. Не подскажете, как поправить ее? Или хотя бы направьте в нужную сторону. По виду символов в целевой визуализации однозначно понятно, что установлена западная кодировка, сравнивал на компьютере. Спасибо.


Вернуться к началу
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 11, 2010 11:17 am 
Не в сети

Зарегистрирован: Ср июн 20, 2007 12:10 pm
Сообщения: 31
Для web-визуализации ответ здесь http://forum-ru.3s-software.com/viewtopic.php?t=746 + поставить на комп последнюю java-машину (у меня version 6 update 16).
Для целевой решение не знаю, т.к. не было необходимости.


Вернуться к началу
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 11, 2010 11:33 am 
Не в сети

Зарегистрирован: Пн сен 28, 2009 1:14 pm
Сообщения: 0
Спасибо. С веб вроде как разобрался немного. Но намного больше интересует именно целевая визуализация. Но все равно спасибо.


Вернуться к началу
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 11, 2010 11:48 am 
Не в сети

Зарегистрирован: Ср июн 20, 2007 12:10 pm
Сообщения: 31
AGluk какую версию Codesys (среда разработки) вы используете для работы с Вашим ПЛК?
Хоть мы целевую визуализацию не используем в проекте, но попробовать успели. Так вот при попытки использовать целевую визуализацию из Codesys 2.3.8.4 и старше компиляция проекта валится с ошибкой "Unresolved external POUs" в библиотеке SysLibTargetVisu.


Вернуться к началу
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 11, 2010 11:58 am 
Не в сети

Зарегистрирован: Пн сен 28, 2009 1:14 pm
Сообщения: 0
Avgur писал(а):
Так вот при попытки использовать целевую визуализацию из Codesys 2.3.8.4 и старше компиляция проекта валится с ошибкой "Unresolved external POUs" в библиотеке SysLibTargetVisu.


Данную проблему я решил заменой файлов из более старой версии CoDeSys. Теперь все проходит без ошибок. А вот русские шрифты отображаются кракозябрами... :(

Версия CoDeSys - 2.3.9.14.


Вернуться к началу
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 11, 2010 12:05 pm 
Не в сети

Зарегистрирован: Ср июн 20, 2007 12:10 pm
Сообщения: 31
AGluk писал(а):
Данную проблему я решил заменой файлов из более старой версии CoDeSys. Теперь все проходит без ошибок.

Можно подробное описание решения (какие файлы заменить)?


Вернуться к началу
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 11, 2010 12:25 pm 
Не в сети

Зарегистрирован: Пн сен 28, 2009 1:14 pm
Сообщения: 0
Ну в моем случае это был файл SysLibTargetVisu.lib из каталога:

c:\Program Files\3S Software\CoDeSys V2.3\Targets\Libraries\ThinkIO\

Полагаю для других ПЛК последняя папка будет другой... Мне прислали данный файл из Kontron.
Вполне возможно что у Вас вообще другая причина ошибки. На всякий случай сохраните все файлы перед заменой.
У меня подозрение вызвал данный файл по причине даты создания. В папке он единственный отличался от остальных. Посмотрите, может у Вас тоже какой файл выделяется...


Вернуться к началу
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 11, 2010 2:09 pm 
Не в сети

Зарегистрирован: Ср июн 20, 2007 12:10 pm
Сообщения: 31
Спасибо, все получилось!
Решение в моем случае: заменить файл SysLibTargetVisu.lib с меткой времени 28.03.2008 файлом с меткой времени 14.12.2007 Небольшое уточнение - эти файлы не принадлежат среде разработки Codesys, а ставятся при установке target для соответствующего ПЛК. Т.е. при обновлении таргетов библиотека заменялась на более новую и получался конфликт с реализацией новых функций в самом ПЛК.


Вернуться к началу
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 11, 2010 2:34 pm 
Не в сети

Зарегистрирован: Пн сен 28, 2009 1:14 pm
Сообщения: 0
Да, я в курсе, что данные файлы ставятся при установке конфигурации под конкретный ПЛК. Рад, что у Вас получилось.
А мне бы вот с русским языком разобраться... Kontron советует в 3S обратиться :) стрелки переводят.


Вернуться к началу
 Заголовок сообщения:
СообщениеДобавлено: Ср янв 13, 2010 12:56 pm 
Не в сети

Зарегистрирован: Ср июн 20, 2007 12:10 pm
Сообщения: 31
Если есть время и желание, можно попробовать добавить поддержку русского языка в ядро linux контроллера. На установочном диске поставляется Linux Support Package в виде rpm-пакета и кросс-компилятор. Инструкция по сборке ядра Linux и RTAI есть в файле Programming-Assistance-Guide-Linux.pdf
Сам компилировал ядро с поддержкой преобразователя usb-serial типа pl2303 в качестве загрузочного модуля. Как добавить пакет для русификации linux (например, kbd) к существующему ядру мне знаний не хватило :oops:


Вернуться к началу
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 25, 2010 3:34 pm 
Не в сети

Зарегистрирован: Пн сен 28, 2009 1:14 pm
Сообщения: 0
Да... и я тоже застрял на добавлении пакета kdb. Вообще, добавление пакета это просто копирование всех его файлов по нужным папкам. Я собирал пакет на основной машине с определенным префиксом (--pefix=...), затем собирал его (make) и устанавливал (make install). Затем из папки копировал его на ПЛК. Пытаясь запустить затем какую-либо команду из данного пакета, получал сообщение, что версия glibc неверная. При попытке заменить версию на необходимую, ПЛК отказывался запускаться вообще. Чувствую, что мне не хватает знаний. Если кто знает, или просто более опытный в linux, подскажите, пожалуйста, как хоть поставить этот пакет? На ПЛК версия glibc 2.3.3, а ему нужна версия 2.3.4 или 2.4, я сам толком не понял. Спасибо!


Вернуться к началу
Показать сообщения за:  Поле сортировки  
Начать новую тему  Ответить на тему  [ 27 сообщений ]  На страницу Пред. 1 2

Часовой пояс: UTC+01:00


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 2 гостя


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Limited
Русская поддержка phpBB